import re
regex = re.compile(r"#([a-zA-Z0-9-_]+)$", flags=re.MULTILINE)
test_str = ("http://blabla.com/test#hashhere\n"
"http://blabla.com/test#hashHere\n"
"http://blabla.com/test#hash-name\n"
"http://blabla.com/test#hash_here\n"
"http://blabla.com/test#hash1\n"
"http://blabla.com/test#hash_1\n"
"http://blabla.com/test#hash-1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")