re = /#([a-zA-Z0-9-_]+)$/m
str = 'http://blabla.com/test#hashhere
http://blabla.com/test#hashHere
http://blabla.com/test#hash-name
http://blabla.com/test#hash_here
http://blabla.com/test#hash1
http://blabla.com/test#hash_1
http://blabla.com/test#hash-1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end