# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\s\S]{1,200})[\s]+?[\s\S]+/$1/g;t' <<< "I have a code snippet written in PHP that pulls a block of text from a database and sends it out to a widget on a webpage. The original block of text can be a lengthy article or a short sentence orrrr two; but for this widget I can't display more than, say, 200 characters. I could use substr() to chop off the text at 200 chars, but the result would be cutting off in the middle of words-- what I really want is to chop the text at the end of the last word before 200 chars."