re = /"[^"]*"(*SKIP)(*F)|\|/
str = 'field|field|field|field|another "field"|field
field|field|field|"another" field|field|field
field|"fie|ld"|field|field|field|field'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end