// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""[^"]*"(*SKIP)(*F)|\|"#).unwrap();
let string = "field|field|field|field|another \"field\"|field
field|field|field|\"another\" field|field|field
field|\"fie|ld\"|field|field|field|field";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}