import re
regex = re.compile(r"[/(Jan) (\d{1,2})/gi, /(Feb) (\d{1,2})/gi, /(Mar) (\d{1,2})/gi, /(Apr) (\d{1,2})/gi, /(May) (\d{1,2})/gi,/(Jun) (\d{1,2})/gi, /(Jul) (\d{1,2})/gi, /(Aug) (\d{1,2})/gi, /(Sep) (\d{1,2})/gi, /(Oct) (\d{1,2})/gi, /(Nov) (\d{1,2})/gi, /(Dec) (\d{1,2})/gi]", flags=re.IGNORECASE)
test_str = "Tue Jun 08 17:37:41 +0000 2015"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")