re = /[\/(Jan) (\d{1,2})\/gi, \/(Feb) (\d{1,2})\/gi, \/(Mar) (\d{1,2})\/gi, \/(Apr) (\d{1,2})\/gi, \/(May) (\d{1,2})\/gi,\/(Jun) (\d{1,2})\/gi, \/(Jul) (\d{1,2})\/gi, \/(Aug) (\d{1,2})\/gi, \/(Sep) (\d{1,2})\/gi, \/(Oct) (\d{1,2})\/gi, \/(Nov) (\d{1,2})\/gi, \/(Dec) (\d{1,2})\/gi]/i
str = 'Tue Jun 08 17:37:41 +0000 2015'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end