using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(/|^))(((/|^)|(\w*:))(?<node>.*?))(?=/|$)";
string substitution = @"*[local-name()='${node}']";
string input = @"elem1/ns:elem2/ns2:elem3/@name
/elem/n:node1/node2/c:node3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}