const regex = new RegExp('(?<=(/|^))(((/|^)|(\\w*:))(?<node>.*?))(?=/|$)', 'gm')
const str = `elem1/ns:elem2/ns2:elem3/@name
/elem/n:node1/node2/c:node3`;
const subst = `*[local-name()='${node}']`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);