$re = '/</transactionshares>(.*)<transactionacquireddisposedcode>/m';
$str = '<nonderivativetransaction><securitytitle><value>Common Stock</value></securitytitle><transactiondate><value>2003-08-19</value></transactiondate><transactioncoding><transactionformtype>4</transactionformtype><transactioncode>S</transactioncode><equityswapinvolved>0</equityswapinvolved></transactioncoding><transactionamounts><transactionshares><value>100</value></transactionshares><\\ntransactionPricePerShare><value>42.31</value><transactionacquireddisposedcode><value>D</value></transactionacquireddisposedcode></transactionamounts><posttransactionamounts><sharesownedfollowingtransaction><value>82291</value></sharesownedfollowingtransaction></posttransactionamounts><ownershipnature><directorindirectownership><value>D</value></directorindirectownership><natureofownership><value></value></natureofownership></ownershipnature></nonderivativetransaction>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);