import re
regex = re.compile(r"</transactionshares>(.*)<transactionacquireddisposedcode>", flags=re.MULTILINE)
test_str = "<nonderivativetransaction><securitytitle><value>Common Stock</value></securitytitle><transactiondate><value>2003-08-19</value></transactiondate><transactioncoding><transactionformtype>4</transactionformtype><transactioncode>S</transactioncode><equityswapinvolved>0</equityswapinvolved></transactioncoding><transactionamounts><transactionshares><value>100</value></transactionshares><\\ntransactionPricePerShare><value>42.31</value><transactionacquireddisposedcode><value>D</value></transactionacquireddisposedcode></transactionamounts><posttransactionamounts><sharesownedfollowingtransaction><value>82291</value></sharesownedfollowingtransaction></posttransactionamounts><ownershipnature><directorindirectownership><value>D</value></directorindirectownership><natureofownership><value></value></natureofownership></ownershipnature></nonderivativetransaction>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")