#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<tag>.*?\K((?:<!|!<)CDATA\[.*?\]+>+)(?=.*<\/tag>)"
Local $sString = "<tag>data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....</tag>" & @CRLF & _
"" & @CRLF & _
"<tag>data......otherdata..!<CDATA[....]>>....</tag>" & @CRLF & _
"" & @CRLF & _
"<tag>data......otherdata......</tag>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<tag>data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>...." & @CRLF & _
"" & @CRLF & _
"data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....</tag>" & @CRLF & _
"" & @CRLF & _
"<tag2>data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....</tag2>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)