$re = '/<tag>.*?\K((?:<!|!<)CDATA\[.*?\]+>+)(?=.*<\/tag>)/m';
$str = '<tag>data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....</tag>
<tag>data......otherdata..!<CDATA[....]>>....</tag>
<tag>data......otherdata......</tag>
<tag>data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....
data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....</tag>
<tag2>data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....</tag2>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;