import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<tag>.*?\\K(?!<!CDATA\\[[^\\n\\]]*\\]>(?:[^>]|$))((?:<!|!<)CDATA\\[.*?\\]+>+)(?=.*<\\/tag>)";
final String string = "<tag>data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....</tag>\n\n"
+ "<tag>data......otherdata..!<CDATA[....]>>....</tag>\n\n"
+ "<tag>data...!<CDATA[|]]>...otherdata......</tag>\n\n"
+ "<tag>data...<!CDATA[asdfghjkl]>...otherdata......</tag>\n\n\n\n\n"
+ "<tag>data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....\n\n"
+ "data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....</tag>\n\n"
+ "<tag2>data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....</tag2>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}