const regex = /<tag>.*?\K(?!<!CDATA\[[^\n\]]*\]>(?:[^>]|$))((?:<!|!<)CDATA\[.*?\]+>+)(?=.*<\/tag>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<tag>.*?\\K(?!<!CDATA\\[[^\\n\\]]*\\]>(?:[^>]|$))((?:<!|!<)CDATA\\[.*?\\]+>+)(?=.*<\\\/tag>)', 'gm')
const str = `<tag>data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....</tag>
<tag>data......otherdata..!<CDATA[....]>>....</tag>
<tag>data...!<CDATA[|]]>...otherdata......</tag>
<tag>data...<!CDATA[asdfghjkl]>...otherdata......</tag>
<tag>data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....
data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....</tag>
<tag2>data...<!CDATA[...]]>...otherdata..!<CDATA[....]>>....</tag2>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);