using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-7]\.|^8.([0-3][0-9]|4[0-3]|44.0.([0-3][0-9]))";
string input = @"8.44.0.39
8.43.0.56
8.44.0.55";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}