import re
regex = re.compile(r"^[0-7]\.|^8.([0-3][0-9]|4[0-3]|44.0.([0-3][0-9]))", flags=re.MULTILINE)
test_str = ("8.44.0.39\n"
"8.43.0.56\n"
"8.44.0.55")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")