$re = '/(Site\:(?<vendorinfo>[\s|\w]*)\,)?(Server\sName\:(?<dname>[\s|\w]*)\,)?(Domain\sName\:(?<group>[\s|\w]*)\,)((?<reason>[\s|\w]*)\,)((?<sname>[\s|\w|\.|\-|_|\d]*)\,)((?<login>[[\s|\w|\.|\-|_|\d]*)\,)((?<domain>[[\s|\w|\.|\-|_|\d]*))/m';
$str = '04 22 2020 17:12:59 10.15.24.173 <LPTR:INFO> Apr 22 17:13:07 Rhantiv03 SymantecServer: Site: Rhantiv03,Server Name: Rhantiv04,Domain Name: Default,The client has downloaded the content package successfully,sp.local,mhAlyamy,SP.LOCAL
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);