// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(Site\:(?<vendorinfo>[\s|\w]*)\,)?(Server\sName\:(?<dname>[\s|\w]*)\,)?(Domain\sName\:(?<group>[\s|\w]*)\,)((?<reason>[\s|\w]*)\,)((?<sname>[\s|\w|\.|\-|_|\d]*)\,)((?<login>[[\s|\w|\.|\-|_|\d]*)\,)((?<domain>[[\s|\w|\.|\-|_|\d]*))").unwrap();
let string = "04 22 2020 17:12:59 10.15.24.173 <LPTR:INFO> Apr 22 17:13:07 Rhantiv03 SymantecServer: Site: Rhantiv03,Server Name: Rhantiv04,Domain Name: Default,The client has downloaded the content package successfully,sp.local,mhAlyamy,SP.LOCAL
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}