import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:-|[0-9]).*|(?<=\\n\\n)(?:-|[0-9])(?:.|\\n)*?(?=\\n+[^-0-9]|$)";
final String string = "- one\n\n"
+ "some text\n"
+ "- should not start a list\n\n"
+ "- should start\n"
+ "- should continue\n\n"
+ "5. should also\n"
+ "6. more";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}