$re = '/^(?:-|[0-9]).*|(?<=\n\n)(?:-|[0-9])(?:.|\n)*?(?=\n+[^-0-9]|$)/';
$str = '- one
some text
- should not start a list
- should start
- should continue
5. should also
6. more';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);