// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?:2[0-5][0-5]|1?[1-9]\d?|0)\.(?:2[0-5][0-5]|1?[1-9]\d?|0)\.(?:2[0-5][0-5]|1?[1-9]\d?|0)\.(?:2[0-5][0-5]|1?[1-9]\d?|0)$").unwrap();
let string = "123.123.123.123";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}