import re
regex = re.compile(r"^@ heading2$[\s\S]*?^(?:field2: \"?((?<=\")[^\"\\]*(?:\\.[^\"\\]*)*(?=\"$)|(?<!\").*(?!\")$)\"?$|)?$[\s\S]*?(?=@ [^\s]*?|\Z)", flags=re.MULTILINE)
test_str = ("@ heading1\n"
"field1: \"single-line strings are quoted only sometimes.\"\n"
"field2: \"strings that span\n"
"multiple lines\n"
"are always quoted.\"\n"
"field3: this single-line string is unquoted.\n\n"
"@ heading2\n"
"field1: field names can be repeated among headings.\n"
"field2: \"Regex is harder when I add an\n"
"@ in a multi-line string, or if I add\n"
"backslash-escaped characters like \\\" and \\'.\n\n"
"What happens if I have an empty line in a string?\n\n"
"Also,\n"
"[this line]\n"
"isn't actually a section.\"\n"
"field3: this field comes after field2\n"
"[sectionname]\n"
"field1: the same field name under a different section.\n"
"[anothersection]\n"
"field1: a second section under the same heading\n"
"field4: field number four\n\n"
"@ heading3\n"
"field1: value value value value value\n"
"field2: \"quoted string\n"
"quoted string\n"
"quoted string\"\n"
"unique: unique field name")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")