package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S+(?:\sAND\s\S+)*`)
var str = `split this but don't split this AND this`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}