$re = '/\S+(?:\sAND\s\S+)*/';
$str = 'split this but don\'t split this AND this';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);