const regex = /^[-]?([0-9]+([.][0-9]*)?(e[-]?[0-9]+)?|[.][0-9]+(e[-]?[0-9]+)?)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[-]?([0-9]+([.][0-9]*)?(e[-]?[0-9]+)?|[.][0-9]+(e[-]?[0-9]+)?)$', 'mg')
const str = `0
1
-0
-1
+0
+1
01
-01
+01
2.3
-2.3
1.00
0.00
-0.00
00.00
-00.00
02.3
.0
.1
-.1
0.
1.
10.
2,3
,0
0e0
2e5
2.3e5
-2.3e5
2.3e-5
2.3e03
2.3e0
0.01e4
.1e5
-.1e5
-.0e0
-0.0e10
2,3e5
.
-
-.
b1
1b
2-3
3.4.5
4.,6
1,.
e
-e
-.e
.e4
1e2-2
e2.3
e2.3.4
-e10
1e.-
10e.
1\\n
1\\t
1 1
\\n
\\t
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}