// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[-]?([0-9]+([.][0-9]*)?(e[-]?[0-9]+)?|[.][0-9]+(e[-]?[0-9]+)?)$").unwrap();
let string = "0
1
-0
-1
+0
+1
01
-01
+01
2.3
-2.3
1.00
0.00
-0.00
00.00
-00.00
02.3
.0
.1
-.1
0.
1.
10.
2,3
,0
0e0
2e5
2.3e5
-2.3e5
2.3e-5
2.3e03
2.3e0
0.01e4
.1e5
-.1e5
-.0e0
-0.0e10
2,3e5
.
-
-.
b1
1b
2-3
3.4.5
4.,6
1,.
e
-e
-.e
.e4
1e2-2
e2.3
e2.3.4
-e10
1e.-
10e.
1\\n
1\\t
1 1
\\n
\\t
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}