import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td>(.*)<\\/td>.*\\n<td>(.*)";
final String string = "Retrieved June 7, 2014\n"
+ "Revision: http://wiki.scribus.net/wiki/index.php?title=Keyboard_Shortcuts_by_Key&oldid=30255\n\n"
+ "Function Keys\n\n"
+ "<table>\n"
+ "<tr>\n"
+ "<td> A </td>\n"
+ "<td> Insert Table Frame\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> B </td>\n"
+ "<td> Insert Bezier Curve\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> C </td>\n"
+ "<td> Select (Temporary until the rest are sorted out)\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> E </td>\n"
+ "<td> Edit Contents (text in a text frame, or image location in an image frame)\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> F </td>\n"
+ "<td> Insert Freehand Line\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> I </td>\n"
+ "<td> Insert Image Frame\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> N </td>\n"
+ "<td> Link Text Frame\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> L </td>\n"
+ "<td> Insert Line\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> P </td>\n"
+ "<td> Insert Polygon\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> R </td>\n"
+ "<td> Rotate\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> S </td>\n"
+ "<td> Insert Shape\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> T </td>\n"
+ "<td> Insert Text Frame\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> U </td>\n"
+ "<td> Unlink Text Frame\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Z </td>\n"
+ "<td> Zoom\n"
+ "</td></tr></table>\n\n"
+ "Normal Keyboard Shortcuts\n\n"
+ "<table>\n"
+ "<tr>\n"
+ "<td> A </td>\n"
+ "<td> Insert Table Frame\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> B </td>\n"
+ "<td> Insert Bezier Curve\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> C </td>\n"
+ "<td> Select (Temporary until the rest are sorted out)\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> E </td>\n"
+ "<td> Edit Contents (text in a text frame, or image location in an image frame)\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> F </td>\n"
+ "<td> Insert Freehand Line\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> I </td>\n"
+ "<td> Insert Image Frame\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> N </td>\n"
+ "<td> Link Text Frame\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> L </td>\n"
+ "<td> Insert Line\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> P </td>\n"
+ "<td> Insert Polygon\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> R </td>\n"
+ "<td> Rotate\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> S </td>\n"
+ "<td> Insert Shape\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> T </td>\n"
+ "<td> Insert Text Frame\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> U </td>\n"
+ "<td> Unlink Text Frame\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Z </td>\n"
+ "<td> Zoom\n"
+ "</td></tr></table>\n\n"
+ "Control, Shift, Alt keys\n\n"
+ "<tr>\n"
+ "<td> Select All </td>\n"
+ "<td> Control-A\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Deselect All </td>\n"
+ "<td> Control-Shift-A\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Copy </td>\n"
+ "<td> Control-C\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Get Text or Image </td>\n"
+ "<td> Control-D\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Item Duplicate </td>\n"
+ "<td> Control-Alt-Shift-D\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Search and Replace </td>\n"
+ "<td> Control-F\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Lock Item </td>\n"
+ "<td> Control-L\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Lock Item Size </td>\n"
+ "<td> Control-Shift-L\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Group Items </td>\n"
+ "<td> Control-G\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Document Information </td>\n"
+ "<td> Control-I\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Delete Item </td>\n"
+ "<td> Control-K\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> New File </td>\n"
+ "<td> Control-N\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Open File </td>\n"
+ "<td> Control-O\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Print </td>\n"
+ "<td> Control-P\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Quit </td>\n"
+ "<td> Control-Q\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Save </td>\n"
+ "<td> Control-S\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Save As </td>\n"
+ "<td> Control-Shift-S\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Ungroup Item </td>\n"
+ "<td> Control-Shift-G\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Paste </td>\n"
+ "<td> Control-V\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Close File </td>\n"
+ "<td> Control-W\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Cut </td>\n"
+ "<td> Control-X\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Edit with Story Editor </td>\n"
+ "<td> Control-Y\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Undo </td>\n"
+ "<td> Control-Z\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Redo </td>\n"
+ "<td> Control-Shift-Z\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Select All </td>\n"
+ "<td> Control-A\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> DeSelect All </td>\n"
+ "<td> Control-Shift-A\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Zoom to fit </td>\n"
+ "<td> Control-0\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Zoom to 100% </td>\n"
+ "<td> Control-1\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Zoom In </td>\n"
+ "<td> Control-Plus\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Zoom Out </td>\n"
+ "<td> Control-Minus\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Zoom In/Out </td>\n"
+ "<td> Control-Mousewheel\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Smart Hyphen </td>\n"
+ "<td> Control-Shift-Minus\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Non Breaking Space </td>\n"
+ "<td> Control-Space\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Insert Page Number </td>\n"
+ "<td> Control-Alt-Shift-P\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Raise </td>\n"
+ "<td> Control-Home\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Lower </td>\n"
+ "<td> Control-End\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Raise to top </td>\n"
+ "<td> Home\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Lower to bottom </td>\n"
+ "<td> End\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Frame Break </td>\n"
+ "<td> Control-Return\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Column Break </td>\n"
+ "<td> Control-Shift-Return\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Stacked Objects, next in Z-order </td>\n"
+ "<td> Control-Shift-LMouse\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Resizing object when other object on top </td>\n"
+ "<td> Control-drag\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Resize proportionally </td>\n"
+ "<td> Control-drag\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Move image in image frame without entering frame edit mode </td>\n"
+ "<td> Control-Alt-drag\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Move frame/group with X/Y constrained </td>\n"
+ "<td> Control-drag\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Rotate a line or when creating a line, constrain the angle of rotation </td>\n"
+ "<td> Control-drag and rotate\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Rotate an existing item on the page other than a line and constrain the angle of rotation </td>\n"
+ "<td> Control-drag and rotate\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Resize to a square </td>\n"
+ "<td> Shift-drag\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> New Line </td>\n"
+ "<td> Shift-Return\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Scale text </td>\n"
+ "<td> Alt-Shift-drag\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Scale text proportionally </td>\n"
+ "<td> Alt-Control-drag\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Move item 1 unit (current: pt,mm,in,c,p,cm)</td>\n"
+ "<td> Arrow keys\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Move item 0.1 units (current: pt,mm,in,c,p,cm)</td>\n"
+ "<td> Shift+Arrow keys\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Move item 10 units (current: pt,mm,in,c,p,cm)</td>\n"
+ "<td> Control+Arrow keys\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Move item 0.01 units (current: pt,mm,in,c,p,cm)</td>\n"
+ "<td> Control+Shift+Arrow keys\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Resize item 1 unit outwards (current: pt,mm,in,c,p,cm)</td>\n"
+ "<td> Alt+Arrow keys\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Resize item 1 unit inwards(current: pt,mm,in,c,p,cm)</td>\n"
+ "<td> Shift+Alt+Arrow keys\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Move to start of paragraph in text edit mode on canvas </td>\n"
+ "<td> Control Up Arrow\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Move to end of paragraph in text edit mode on canvas </td>\n"
+ "<td> Control Down Arrow\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Move to start of frame in text edit mode on canvas </td>\n"
+ "<td> Control Page Up\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Move to end of frame in text edit mode on canvas </td>\n"
+ "<td> Control Page Down\n"
+ "</td></tr>\n"
+ "<tr>\n"
+ "<td> Resize image while in image frame edit mode on canvas </td>\n"
+ "<td> Alt+Arrow keys\n"
+ "</td></tr></table>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}