// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<td>(.*)<\/td>.*\n<td>(.*)").unwrap();
let string = "Retrieved June 7, 2014
Revision: http://wiki.scribus.net/wiki/index.php?title=Keyboard_Shortcuts_by_Key&oldid=30255
Function Keys
<table>
<tr>
<td> A </td>
<td> Insert Table Frame
</td></tr>
<tr>
<td> B </td>
<td> Insert Bezier Curve
</td></tr>
<tr>
<td> C </td>
<td> Select (Temporary until the rest are sorted out)
</td></tr>
<tr>
<td> E </td>
<td> Edit Contents (text in a text frame, or image location in an image frame)
</td></tr>
<tr>
<td> F </td>
<td> Insert Freehand Line
</td></tr>
<tr>
<td> I </td>
<td> Insert Image Frame
</td></tr>
<tr>
<td> N </td>
<td> Link Text Frame
</td></tr>
<tr>
<td> L </td>
<td> Insert Line
</td></tr>
<tr>
<td> P </td>
<td> Insert Polygon
</td></tr>
<tr>
<td> R </td>
<td> Rotate
</td></tr>
<tr>
<td> S </td>
<td> Insert Shape
</td></tr>
<tr>
<td> T </td>
<td> Insert Text Frame
</td></tr>
<tr>
<td> U </td>
<td> Unlink Text Frame
</td></tr>
<tr>
<td> Z </td>
<td> Zoom
</td></tr></table>
Normal Keyboard Shortcuts
<table>
<tr>
<td> A </td>
<td> Insert Table Frame
</td></tr>
<tr>
<td> B </td>
<td> Insert Bezier Curve
</td></tr>
<tr>
<td> C </td>
<td> Select (Temporary until the rest are sorted out)
</td></tr>
<tr>
<td> E </td>
<td> Edit Contents (text in a text frame, or image location in an image frame)
</td></tr>
<tr>
<td> F </td>
<td> Insert Freehand Line
</td></tr>
<tr>
<td> I </td>
<td> Insert Image Frame
</td></tr>
<tr>
<td> N </td>
<td> Link Text Frame
</td></tr>
<tr>
<td> L </td>
<td> Insert Line
</td></tr>
<tr>
<td> P </td>
<td> Insert Polygon
</td></tr>
<tr>
<td> R </td>
<td> Rotate
</td></tr>
<tr>
<td> S </td>
<td> Insert Shape
</td></tr>
<tr>
<td> T </td>
<td> Insert Text Frame
</td></tr>
<tr>
<td> U </td>
<td> Unlink Text Frame
</td></tr>
<tr>
<td> Z </td>
<td> Zoom
</td></tr></table>
Control, Shift, Alt keys
<tr>
<td> Select All </td>
<td> Control-A
</td></tr>
<tr>
<td> Deselect All </td>
<td> Control-Shift-A
</td></tr>
<tr>
<td> Copy </td>
<td> Control-C
</td></tr>
<tr>
<td> Get Text or Image </td>
<td> Control-D
</td></tr>
<tr>
<td> Item Duplicate </td>
<td> Control-Alt-Shift-D
</td></tr>
<tr>
<td> Search and Replace </td>
<td> Control-F
</td></tr>
<tr>
<td> Lock Item </td>
<td> Control-L
</td></tr>
<tr>
<td> Lock Item Size </td>
<td> Control-Shift-L
</td></tr>
<tr>
<td> Group Items </td>
<td> Control-G
</td></tr>
<tr>
<td> Document Information </td>
<td> Control-I
</td></tr>
<tr>
<td> Delete Item </td>
<td> Control-K
</td></tr>
<tr>
<td> New File </td>
<td> Control-N
</td></tr>
<tr>
<td> Open File </td>
<td> Control-O
</td></tr>
<tr>
<td> Print </td>
<td> Control-P
</td></tr>
<tr>
<td> Quit </td>
<td> Control-Q
</td></tr>
<tr>
<td> Save </td>
<td> Control-S
</td></tr>
<tr>
<td> Save As </td>
<td> Control-Shift-S
</td></tr>
<tr>
<td> Ungroup Item </td>
<td> Control-Shift-G
</td></tr>
<tr>
<td> Paste </td>
<td> Control-V
</td></tr>
<tr>
<td> Close File </td>
<td> Control-W
</td></tr>
<tr>
<td> Cut </td>
<td> Control-X
</td></tr>
<tr>
<td> Edit with Story Editor </td>
<td> Control-Y
</td></tr>
<tr>
<td> Undo </td>
<td> Control-Z
</td></tr>
<tr>
<td> Redo </td>
<td> Control-Shift-Z
</td></tr>
<tr>
<td> Select All </td>
<td> Control-A
</td></tr>
<tr>
<td> DeSelect All </td>
<td> Control-Shift-A
</td></tr>
<tr>
<td> Zoom to fit </td>
<td> Control-0
</td></tr>
<tr>
<td> Zoom to 100% </td>
<td> Control-1
</td></tr>
<tr>
<td> Zoom In </td>
<td> Control-Plus
</td></tr>
<tr>
<td> Zoom Out </td>
<td> Control-Minus
</td></tr>
<tr>
<td> Zoom In/Out </td>
<td> Control-Mousewheel
</td></tr>
<tr>
<td> Smart Hyphen </td>
<td> Control-Shift-Minus
</td></tr>
<tr>
<td> Non Breaking Space </td>
<td> Control-Space
</td></tr>
<tr>
<td> Insert Page Number </td>
<td> Control-Alt-Shift-P
</td></tr>
<tr>
<td> Raise </td>
<td> Control-Home
</td></tr>
<tr>
<td> Lower </td>
<td> Control-End
</td></tr>
<tr>
<td> Raise to top </td>
<td> Home
</td></tr>
<tr>
<td> Lower to bottom </td>
<td> End
</td></tr>
<tr>
<td> Frame Break </td>
<td> Control-Return
</td></tr>
<tr>
<td> Column Break </td>
<td> Control-Shift-Return
</td></tr>
<tr>
<td> Stacked Objects, next in Z-order </td>
<td> Control-Shift-LMouse
</td></tr>
<tr>
<td> Resizing object when other object on top </td>
<td> Control-drag
</td></tr>
<tr>
<td> Resize proportionally </td>
<td> Control-drag
</td></tr>
<tr>
<td> Move image in image frame without entering frame edit mode </td>
<td> Control-Alt-drag
</td></tr>
<tr>
<td> Move frame/group with X/Y constrained </td>
<td> Control-drag
</td></tr>
<tr>
<td> Rotate a line or when creating a line, constrain the angle of rotation </td>
<td> Control-drag and rotate
</td></tr>
<tr>
<td> Rotate an existing item on the page other than a line and constrain the angle of rotation </td>
<td> Control-drag and rotate
</td></tr>
<tr>
<td> Resize to a square </td>
<td> Shift-drag
</td></tr>
<tr>
<td> New Line </td>
<td> Shift-Return
</td></tr>
<tr>
<td> Scale text </td>
<td> Alt-Shift-drag
</td></tr>
<tr>
<td> Scale text proportionally </td>
<td> Alt-Control-drag
</td></tr>
<tr>
<td> Move item 1 unit (current: pt,mm,in,c,p,cm)</td>
<td> Arrow keys
</td></tr>
<tr>
<td> Move item 0.1 units (current: pt,mm,in,c,p,cm)</td>
<td> Shift+Arrow keys
</td></tr>
<tr>
<td> Move item 10 units (current: pt,mm,in,c,p,cm)</td>
<td> Control+Arrow keys
</td></tr>
<tr>
<td> Move item 0.01 units (current: pt,mm,in,c,p,cm)</td>
<td> Control+Shift+Arrow keys
</td></tr>
<tr>
<td> Resize item 1 unit outwards (current: pt,mm,in,c,p,cm)</td>
<td> Alt+Arrow keys
</td></tr>
<tr>
<td> Resize item 1 unit inwards(current: pt,mm,in,c,p,cm)</td>
<td> Shift+Alt+Arrow keys
</td></tr>
<tr>
<td> Move to start of paragraph in text edit mode on canvas </td>
<td> Control Up Arrow
</td></tr>
<tr>
<td> Move to end of paragraph in text edit mode on canvas </td>
<td> Control Down Arrow
</td></tr>
<tr>
<td> Move to start of frame in text edit mode on canvas </td>
<td> Control Page Up
</td></tr>
<tr>
<td> Move to end of frame in text edit mode on canvas </td>
<td> Control Page Down
</td></tr>
<tr>
<td> Resize image while in image frame edit mode on canvas </td>
<td> Alt+Arrow keys
</td></tr></table>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}