const regex = new RegExp('<(?P<name1>\\w*)><(?P<name2>h[1-5])>.*</(?P=name2)></(?P=name1)>', 'gm')
const str = `<html><h1>www.baidu.com</h1></html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}