re = /<(?P<name1>\w*)><(?P<name2>h[1-5])>.*<\/(?P=name2)><\/(?P=name1)>/m
str = '<html><h1>www.baidu.com</h1></html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end