$re = '/(\[[\s\S]+?\])/';
$str = '[gallery columns="3" ids="426,425,427"] abc asdasdsad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);