re = /(\[[\s\S]+?\])/
str = '[gallery columns="3" ids="426,425,427"] abc asdasdsad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end