using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\/=\[])([^\/=\[]+)(?=\])";
string input = @"2016-02-17 19:59:18,182 GMT [transaction-Id=47ad8e96-1db8-4b41-85e5-9256fca485ab] [request_uri=/mydevice/2232234] [] INFO Response:{""executionTimeInMillis"":54,""transactionId"":""3191569800"",""success"":false,""internalTransactionId"":""47ad8e96-1db8-4b41-85e5-9256fca485ab"",""operationResults"":[{""operation"":""addDevice"",""code"":""409"",""message"":""Cannot add device""}]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}