import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[\\/=\\[])([^\\/=\\[]+)(?=\\])";
final String string = "2016-02-17 19:59:18,182 GMT [transaction-Id=47ad8e96-1db8-4b41-85e5-9256fca485ab] [request_uri=/mydevice/2232234] [] INFO Response:{\"executionTimeInMillis\":54,\"transactionId\":\"3191569800\",\"success\":false,\"internalTransactionId\":\"47ad8e96-1db8-4b41-85e5-9256fca485ab\",\"operationResults\":[{\"operation\":\"addDevice\",\"code\":\"409\",\"message\":\"Cannot add device\"}]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}