$re = '/.*(\[.*\])/m';
$str = 'atext[d][][ef]
other[aa][][a]
xxxxx[][xx][x][][xx]
yyyyy[]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);