re = /.*(\[.*\])/m
str = 'atext[d][][ef]
other[aa][][a]
xxxxx[][xx][x][][xx]
yyyyy[]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end