$re = '/word1.*(?:\R.*){0,5}(?!.*;$).*word2/mi';
$str = ' any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text word2
any random text any random text;
any random text word1 any random text
any random word2 text any random text word2
any random text any random text
any random text word2 any random text
any random text any random text word2 any random text;
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text
any random text any random text any random text;
any random text any random text word2
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text
any random text word2 any random text;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);