import Foundation
let pattern = #"word1.*(?:\R.*){0,5}(?!.*;$).*word2"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text word2
any random text any random text;
any random text word1 any random text
any random word2 text any random text word2
any random text any random text
any random text word2 any random text
any random text any random text word2 any random text;
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text
any random text any random text any random text;
any random text any random text word2
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text
any random text word2 any random text;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)