package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d\.\d(\.\d*)?$`)
var str = `1.1
1.2
1.2.3
3.7.123
3.19.123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}