$re = '/^\d\.\d(\.\d*)?$/m';
$str = '1.1
1.2
1.2.3
3.7.123
3.19.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);