import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\b(Or rather)\\b),";
final String string = "Or rather, an image.\n\n\n"
+ "or rather, an image.\n\n"
+ "or rather, friends.\n\n"
+ "or rather, an image---\n\n"
+ "Or rather, another time they.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}