re = /^[a-zA-Z\s\d\/\+\(\)\#\&]*$/m
str = 'Card Name #1
Card Name (1)
Card Name / 1
Card Name &1
Card_Name + 1
card -sd
Card_Name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end