package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/?([^/]+)\/?([gmiyusd]+)?,(.+)$`)
var str = `/red/g,green
/red/ig,green
foo,bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}