re = /^\/?([^\/]+)\/?([gmiyusd]+)?,(.+)$/m
str = '/red/g,green
/red/ig,green
foo,bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end