const regex = /[^\x00-\x7FâäèéêëîïôœùûüÿçÀÂÄÈÉÊËÎÏÔŒÙÛÜŸÇ]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\x00-\\x7FâäèéêëîïôœùûüÿçÀÂÄÈÉÊËÎÏÔŒÙÛÜŸÇ]+', '')
const str = `âäèéêëîïôœùûüÿçÀÂÄÈÉÊËÎÏÔŒÙÛÜŸÇłŁĘꥹćĆźŹżŻабвгдеёжзийклмнопрстуфхцчшщъыьэюяЯЁabcdefghijklMNOpqrtuvwxyz`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);