use strict;
my $str = 'âäèéêëîïôœùûüÿçÀÂÄÈÉÊËÎÏÔŒÙÛÜŸÇłŁĘꥹćĆźŹżŻабвгдеёжзийклмнопрстуфхцчшщъыьэюяЯЁabcdefghijklMNOpqrtuvwxyz';
my $regex = qr/[^\x00-\x7FâäèéêëîïôœùûüÿçÀÂÄÈÉÊËÎÏÔŒÙÛÜŸÇ]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";