package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<junk>(?:\\n|^).*?(?:\\n|$))(?<delimiter>Closing Date: )?`)
var str = `hukhkhk\nClosing Date: Friday 22nd April 2022\nwdwqdwqdwqd\nClosing Date: Friday 22nd April 2023\newdewfewf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}