$re = '/(?<junk>(?:\\\\n|^).*?(?:\\\\n|$))(?<delimiter>Closing Date: )?/m';
$str = 'hukhkhk\\nClosing Date: Friday 22nd April 2022\\nwdwqdwqdwqd\\nClosing Date: Friday 22nd April 2023\\newdewfewf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);