using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<new_field_name>[^\-]*$)";
string input = @"id = bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-423447
id = bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-6672
id = bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-4232323";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}